DP Computer Technologies Service - Google Workspace Issues (02/15/2024) – Incident details

Google Workspace Issues (02/15/2024)

Resolved
Degraded performance
Started about 1 year agoLasted about 19 hours

Affected

Business Tools

Degraded performance from 4:30 AM to 11:30 PM

Google Workspace

Degraded performance from 4:30 AM to 11:30 PM

Updates
  • Resolved
    Resolved

    This issue is now resolved. If you are still experiencing issues accessing any Google Workspace services, please create a ticket via our support portal. We appreciate your patience and understanding!

  • Update
    Update

    The Engineering team of Google Workspace has taken necessary steps to mitigate the issue, and it should be resolved by now. However, if anyone is still encountering any problems, please inform us so that we can communicate the issue to Google Workspace's team through their communication channels.

    We will keep monitoring the situation, and any existing issues should be resolved entirely within the next 24 hours.

  • Monitoring
    Monitoring

    According to the Engineering team at Google Workspace, the recent issue has been partially resolved for most customers, but there is no estimated time for a complete resolution. So far, none of our customers have reported any problems, but we are continuously monitoring our communication channels. Any new updates regarding this issue will be posted on this page.

  • Identified
    Identified

    At approximately 2:08 AM UTC, an issue was reported by Google Workspace's engineering team, which is affecting several of their products including Gmail, Google Calendar, Google Chat, and more. Unfortunately, there is no known workaround for this issue at the moment. Our team will provide more information as soon as we are notified by Google Workspace's engineering team.